<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" lang="en" xml:lang="en">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <title> Residents livid about Port’s plans to cut 3,000 trees near SeaTac Airport | West Seattle Herald / White Center News</title>
  
    
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="fb:app_id" content=""/>

<meta property="og:title" content=" Residents livid about Port’s plans to cut 3,000 trees near SeaTac Airport"/>
<meta property="og:site_name" content="West Seattle Herald / White Center News"/>

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="News" href="/feeds/175" />
<meta name="description" content="By Gwen Davis It’s on everyone’s mind: “You’re going to cut down 3,000 trees?! That’s crazy!&quot; The Port of Seattle held an emotional commission meeting on Tuesday afternoon, at the airport’s Central Auditorium. The commission discussed several items related to the airport." />
<meta name="abstract" content="This community's most trusted news source" />
<meta name="keywords" content="Ballard,Fremont,Robinson Newspapers" />
<meta name="copyright" content="Copyright © 2012-2013 Robinson Newspapers" />
<link rel="canonical" href="http://www.westseattleherald.com/2016/11/22/news/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees" />
<meta name="revisit-after" content="1 day" />
  <link type="text/css" rel="stylesheet" media="all" href="http://www.westseattleherald.com/sites/robinsonpapers.com/files/css/css_0362f7246638fc46a7787be5d8f09ebe.css" />
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/grid12-960.css?M"/>
  <!--[if IE 8]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie8-fixes.css?M" />
  <![endif]-->
  <!--[if IE 7]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie7-fixes.css?M" />
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/robinsonnews/css/ie7-fixes.css?M" />
  <![endif]-->
  <!--[if lte IE 6]>
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/fusion/fusion_core/css/ie6-fixes.css?M"/>
<link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/robinsonnews/css/ie6-fixes.css?M"/>
  <![endif]-->
    
  <script type="text/javascript" src="http://www.westseattleherald.com/sites/robinsonpapers.com/files/js/js_7d936fb2b32da1b93660505e0b5cf346.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)sites\/robinsonpapers.com\/files","default_image":"\/modules\/freelock\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.6","overlay_color":"000","disable_close_click":1,"resize_sequence":0,"resize_speed":100,"fade_in_speed":100,"slide_down_speed":100,"use_alt_layout":1,"disable_resize":1,"disable_zoom":0,"force_show_nav":0,"show_caption":1,"loop_items":1,"node_link_text":"View Image Details","node_link_target":0,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003ca href=\"#\" onclick=\"hideLightbox(); return FALSE;\"\u003e\u003ckbd\u003ex\u003c\/kbd\u003e\u003c\/a\u003e to close","download_link_text":"","enable_login":true,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"(\\.thumbnail)","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"img.inline,img.flickr-photo-img,img.flickr-photoset-img,img.ImageFrame_image,img.ImageFrame_none,img.image-img_assist_custom,img.thumbnail, img.image-thumbnail","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":0,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":7000,"slideshow_automatic_start":1,"slideshow_automatic_exit":0,"show_play_pause":1,"pause_on_next_click":1,"pause_on_previous_click":1,"loop_slides":0,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":0},"piwik":{"trackMailto":1},"disqus":{"url":"http:\/\/www.westseattleherald.com\/2016\/11\/22\/news\/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees","title":" Residents livid about Port\u2019s plans to cut 3,000 trees near SeaTac Airport","identifier":"node\/252687","shortname":"westseattleherald"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"},"CToolsUrlIsAjaxTrusted":{"http:\/\/www.westseattleherald.com\/2016\/11\/22\/news\/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees":[true,true]}});
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

	    addthis_pub = 'robinsonnews';
	    addthis_logo = 'http://ballardnewstribune.com/sites/all/themes/robinson_default/images/robinsonico.jpg';
	    addthis_logo_background = 'EFEFFF';
	    addthis_logo_color = '666699';
	    addthis_brand = 'Robinson Newspapers';
	    addthis_options = 'favorites, email, digg, delicious, myspace, facebook, google, live, more';
	    addthis_disable_flash = 'false';
	
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-26788712-1", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.write(unescape("%3Cscript src='//partner.googleadservices.com/gampad/google_service.js' type='text/javascript'%3E%3C/script%3E"));

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GS_googleAddAdSenseService("ca-pub-4956332358238235");
GS_googleEnableAllServices();

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_news_region_1_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_news_region_1_slot_2");
GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_news_region_2_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_news_region_3_slot_1");
GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_news_region_headteasers_slot_1");

//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
GA_googleFetchAds();

//--><!]]>
</script>
  
  <script type="text/javascript" src="http://partner.googleadservices.com/gampad/google_service.js">
  </script>
  <script type="text/javascript">
    GS_googleAddAdSenseService("ca-pub-4956332358238235");
    GS_googleEnableAllServices();
  </script>
  <script type="text/javascript">
    GA_googleUseIframeRendering();
  </script>
  
    <!--[if lte IE 6]>
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/js/supersleight.js"></script>
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/ie6.js"></script>
  <![endif]-->
 
  <script type="text/javascript" src="/sites/all/themes/robinsonnews/js/robinsonnews.js"></script>
 
    	<link href="/feed" title="RSS 2.0" type="application/rss+xml" rel="alternate"/>
  
</head>

<body id="pid-2016-11-22-news-residents-livid-about-port’s-plans-cut-3000-trees" class="not-front not-logged-in page-node node-type-newsstory no-sidebars full-node layout-first-main-last sidebars-split font-size-12 grid-type-960 grid-width-12">
  <div id="page" class="page">
    <div id="page-inner" class="page-inner">
      <div id="skip">
        <a href="#main-content-area">Skip to Main Content Area</a>
      </div>

      <!-- header-top row: width = grid_width -->
      <div id="header-top-wrapper" class="header-top-wrapper full-width">
<div id="header-top" class="header-top row grid12-12">
<div id="header-top-inner" class="header-top-inner inner clearfix">
  
<div id="block-weather-3" class="block block-weather odd first  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      Tuesday, November 22, 2016 | 
    Overcast, light rain, <span style="white-space:nowrap;">50&thinsp;°F</span>  </p>

    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-search-0" class="block block-search even   grid12-4">
  <div class="inner clearfix">
            <h2 class="title block-title">search</h2>
        <div class="content">
      <form action="http://www.westseattleherald.com/2016/11/22/news/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees"  accept-charset="UTF-8" method="post" id="search-block-form">
<div><div id="search" class="container-inline">
  <div class="form-item">
    <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-keys"  size="15" value="" title="Enter the terms you wish to search for." class="form-text" />
  </div>
  <input type="submit" name="op" id="edit-submit" value="Search"  class="form-submit" />
  <input type="hidden" name="form_token" id="edit-search-theme-form-form-token" value="c0d9d7f3314f23e4aacad9718dc08566"  />
  <input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-menu-menu-top-menu" class="block block-menu odd  last  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <ul class="menu"><li class="leaf first"><a href="/letters-to-the-editor">Letters</a></li>
<li class="leaf"><a href="/user">Sign in</a></li>
<li class="leaf"><a href="http://robinsonpapers.com/robinson-newspapers-subscription-form" title="You can use this simple information form to subscribe to ANY of the Robinson Newspapers.">Subscribe</a></li>
<li class="leaf last"><a href="/contact-us" title="Contact our Staff">Contact Us</a></li>
</ul>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /header-top-inner -->
</div><!-- /header-top -->
</div><!-- /header-top-wrapper -->

      <!-- header-group row: width = grid_width -->
      <div id="header-group-wrapper" class="header-group-wrapper full-width">
        <div id="header-group" class="header-group row grid12-12">
          <div id="header-group-inner" class="header-group-inner inner clearfix">
            
            
              
<div id="block-robinson-header_flag" class="block block-robinson odd first last  grid12-12 black-header">
  <div class="inner clearfix">
            <div class="content">
      
<a id="logo" href="/"></a>
<div class="container" id="primary-links">
  <ul id="nav" class="links">
          <li class="first"><a href="/home">Front Page</a></li>          <li class="active"><a href="/news" class="active">News</a></li>          <li class=""><a href="/features">Features</a></li>          <li class=""><a href="/sports">Sports</a></li>          <li class=""><a href="/opinion">Opinion</a></li>          <li class="last"><a href="/police-blotter">Police Blotter</a></li>      </ul>
</div>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
          </div><!-- /header-group-inner -->
        </div><!-- /header-group -->
      </div><!-- /header-group-wrapper -->

      <!-- preface-top row: width = grid_width -->
      <div id="preface-top-wrapper" class="preface-top-wrapper full-width">
<div id="preface-top" class="preface-top row grid12-12">
<div id="preface-top-inner" class="preface-top-inner inner clearfix">
  
<div id="block-robinson-header_teasers" class="block block-robinson odd first last  grid12-12 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="head-teasers">
    <div class="teaser">
        <span class="chop">
                            <a href="/2016/11/21/features/temple-dog-reminds-seattle-sound-still-world">
                    <b>Temple of the Dog reminds that the Seattle sound is still world class</b>
                    In 1990 the music people were listening to had fallen into a ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <div id="gam-holder-west-seattle_news_region_headteasers_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("west-seattle_news_region_headteasers_slot_1");</script></div>                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2016/01/26/features/westside-o-rama-west-seattle-entertainment-gu">
                    <b>Westside-O-Rama West Seattle Entertainment Guide</b>
                    Admiral Theater
2343 California Ave. S.W.
938-3456
Movie ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2016/11/19/sports/westside-snow-report-11-19-16">
                    <b>Westside Snow Report 11-19-16</b>
                    By Greg Whittaker

West Seattle is experiencing a baby boom.   ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2016/11/07/opinion/amandas-view-addiction-face-face-part-two">
                    <b>Amanda's View: Addiction, face-to-face, part two: Tricks and triggers</b>
                    
By Amanda Knox
 
I accelerated into the mostly empty parking ...                </a>
                    </span>
    </div>
    <div class="teaser">
        <span class="chop">
                            <a href="/2016/11/21/police-blotter/police-blotter-week-11-21-16">
                    <b>Police Blotter Week of 11-21-16</b>
                    Police chase burglar on foot

The owners of a home located on ...                </a>
                    </span>
    </div>
</div>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /preface-top-inner -->
</div><!-- /preface-top -->
</div><!-- /preface-top-wrapper -->

<div id="content-container">

      <!-- main row: width = grid_width -->
      <div id="main-wrapper" class="main-wrapper full-width">
        
        <div id="main" class="main row grid12-12">
          <div id="main-inner" class="main-inner inner clearfix">
            <div id="sidebar-first" class="sidebar-first row nested grid12-2">
<div id="sidebar-first-inner" class="sidebar-first-inner inner clearfix">
  
<div id="block-views-stories_by_section-block_1" class="block block-views odd first last  grid12-2 black-header">
  <div class="inner clearfix">
            <h2 class="title block-title">News</h2>
        <div class="content">
      <div class="view view-stories-by-section view-id-stories_by_section view-display-id-block_1 view-dom-id-1">
    
  
  
      <div class="view-content">
      <div class="item-list">
    <ul>
          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/22/news/highline-school-board-hold-hearings-tyee-and">Highline School Board to hold hearings on Tyee and Evergreen Schools</a></span>
  </div>
</li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/22/news/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees" class="active">Residents livid about Port’s plans to cut 3,000 trees near SeaTac Airport</a></span>
  </div>
</li>
          <li class="views-row views-row-3 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/21/news/go-week-11-21-16">On the Go Week of 11-21-16</a></span>
  </div>
</li>
          <li class="views-row views-row-4 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/21/news/two-three-story-apartment-buildings-proposed">Two, three story apartment buildings proposed for Avalon area</a></span>
  </div>
</li>
          <li class="views-row views-row-5 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/21/news/south-seattle-college-inviting-community-college">South Seattle College inviting community to College for Goal Washington Events</a></span>
  </div>
</li>
          <li class="views-row views-row-6 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/20/news/70th-annual-kiwanis-pancake-breakfast-brings">70th Annual Kiwanis Pancake Breakfast brings the tasty on Dec. 3</a></span>
  </div>
</li>
          <li class="views-row views-row-7 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/20/news/new-sculpture-dedicated-junction-plaza-park">New sculpture dedicated in Junction Plaza Park</a></span>
  </div>
</li>
          <li class="views-row views-row-8 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/19/news/welcome-rev-leah-fauntleroy-church-installs-new">&#039;Welcome, Rev. Leah!&#039; ; Fauntleroy Church installs new senior pastor</a></span>
  </div>
</li>
          <li class="views-row views-row-9 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/18/news/west-seattle-weighs-potential-impacts-trump">West Seattle weighs in on potential impacts of Trump Administration</a></span>
  </div>
</li>
          <li class="views-row views-row-10 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/18/news/shelbys-bistro-hosting-series-school-fundraisers">Shelby&#039;s Bistro hosting series of school fundraisers</a></span>
  </div>
</li>
          <li class="views-row views-row-11 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/17/news/white-center-food-bank-dinner-and-auction-set-nov">White Center Food Bank dinner and auction is set for Nov. 18</a></span>
  </div>
</li>
          <li class="views-row views-row-12 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/17/news/faculty-demonstration-south-seattle-college-shows">Faculty demonstration at South Seattle College shows hard differences over teacher pay</a></span>
  </div>
</li>
          <li class="views-row views-row-13 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/17/news/slideshow-seafair-pirates-invade-artswest-theater">SLIDESHOW: Seafair Pirates invade ArtsWest Theater</a></span>
  </div>
</li>
          <li class="views-row views-row-14 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/17/news/alki-ave-townhouse-project-gets-go-ahead">Alki Ave townhouse project gets the go ahead</a></span>
  </div>
</li>
          <li class="views-row views-row-15 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/16/news/northwest-wine-academy-south-seattle-college">Northwest Wine Academy at South Seattle College celebrating their Fall Release Nov. 17-19</a></span>
  </div>
</li>
          <li class="views-row views-row-16 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/15/news/new-sculpture-junction-plaza-park-be-dedicated">New sculpture at Junction Plaza Park to be dedicated Nov. 20</a></span>
  </div>
</li>
          <li class="views-row views-row-17 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/14/news/go-week-11-14-16">On the Go Week of 11-14-16</a></span>
  </div>
</li>
          <li class="views-row views-row-18 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/14/news/sealth-students-stage-walkout-over-election-0">Sealth students stage walkout over election of Donald Trump</a></span>
  </div>
</li>
          <li class="views-row views-row-19 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/12/news/wind-advisory-today-predicts-gusts-45mph-power">Wind Advisory today predicts gusts up to 45mph; Power outages possible</a></span>
  </div>
</li>
          <li class="views-row views-row-20 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/12/news/west-seattle-nursery-holiday-open-house-set-sat">West Seattle Nursery Holiday Open House set for Sat. Nov. 19</a></span>
  </div>
</li>
          <li class="views-row views-row-21 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/11/news/american-legion-post-160-offers-free-dinner-all">American Legion Post 160 offers free dinner to all veterans to honor their service</a></span>
  </div>
</li>
          <li class="views-row views-row-22 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/11/news/veterans-day-flags-go-junction">Veterans Day flags go up in the Junction</a></span>
  </div>
</li>
          <li class="views-row views-row-23 views-row-odd">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/11/news/contract-negotiations-stalled-seattle-colleges">With contract negotiations stalled, Seattle Colleges faculty will stage a walkout Nov. 17</a></span>
  </div>
</li>
          <li class="views-row views-row-24 views-row-even">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/10/news/braseth-42-design-review-meeting-set-dec1-6-story">&#039;Braseth 42&#039; design review meeting set for Dec.1; 6 story, 74 unit mixed use building to be built on 42nd SW.</a></span>
  </div>
</li>
          <li class="views-row views-row-25 views-row-odd views-row-last">  
  <div class="views-field-title">
                <span class="field-content"><a href="/2016/11/10/news/dave-newman-insurance-collecting-warm-clothing">Dave Newman Insurance collecting warm clothing for the needy</a></span>
  </div>
</li>
      </ul>
</div>    </div>
  
  
  
  
  
      <div class="feed-icon">
      <a href="/feeds/175" class="feed-icon"><img src="/misc/feed.png" alt="Syndicate content" title="News" width="16" height="16" /></a>    </div>
  
</div>     </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /sidebar-first-inner -->
</div><!-- /sidebar-first -->

            <!-- main group: width = grid_width - sidebar_first_width -->
            <div id="main-group" class="main-group row nested grid12-10">
              <div id="main-group-inner" class="main-group-inner inner">
                
                <div id="main-content" class="main-content row nested">
                  <div id="main-content-inner" class="main-content-inner inner">
                    <!-- content group: width = grid_width - (sidebar_first_width + sidebar_last_width) -->
                    <div id="content-group" class="content-group row nested grid12-6">
                      <div id="content-group-inner" class="content-group-inner inner">
                        

                        
                        <div id="content-region" class="content-region row nested">
                          <div id="content-region-inner" class="content-region-inner inner">
                            <a name="main-content-area" id="main-content-area"></a>
                                                        <div id="content-inner" class="content-inner block">
                              <div id="content-inner-inner" class="content-inner-inner inner">
                                                                                                <div id="content-content" class="content-content">
                                  
<div class="row">

  <div class="inner clearfix background black-border-top story top-story bottom-margin">
    <div class="section-strip-mini"></div>
          <a rel="lightbox[images]" title="<br />The Port of Seattle held a public meeting Nov. 22 regarding their plan to cut down some 3000 trees in the vicinity of SeaTac Airport." href="http://www.westseattleherald.com/sites/robinsonpapers.com/files/imagecache/popup_image/images/wwwwestseattleheraldcom/2016/11/15205696101057916462014881796340552o.jpg"><img src="http://www.westseattleherald.com/sites/robinsonpapers.com/files/imagecache/3col/images/wwwwestseattleheraldcom/2016/11/15205696101057916462014881796340552o.jpg" alt="" title="" /></a>      <div class='image-credit'>Gwen Davis</div><div class='image-caption'>The Port of Seattle held a public meeting Nov. 22 regarding their plan to cut down some 3000 trees in the vicinity of SeaTac Airport.
</div>        
    <div class="story-content">

          <h2> Residents livid about Port’s plans to cut 3,000 trees near SeaTac Airport</h2>
    
          <h3></h3>
        
    <div class="meta">
            <div class='date_submitted_field'><span class="date-display-single">11/22/2016</span> <span class='updated-time-ago'>updated 1 hour ago</span></div>    </div>

    
      

        
    <p><strong>By Gwen Davis</strong></p>
<p>It’s on everyone’s mind: “You’re going to cut down 3,000 trees?! That’s crazy!"</p>
<p>The Port of Seattle held an emotional commission meeting on Tuesday afternoon, at the airport’s Central Auditorium. The commission discussed several items related to the airport. However, the conversation and testimony regarding the near 3,000 tree-hacking project was the beef of the meeting.<br />
 <div id="gam-holder-west-seattle_story_text_region_slot_1" class="gam-holder"><script type="text/javascript">GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_story_text_region_slot_1");</script><script type="text/javascript">GA_googleFillSlot("west-seattle_story_text_region_slot_1");</script></div></p>
<p>The room was packed — around 40 citizens showed. In addition to the commission members, over a dozen Port of Seattle employees attended, who both stood throughout the meeting, and were seated, scattered throughout the general audience.  </p>
<p>A number of public officials attended the meeting, including state rep. Tina Orwell.</p>
<p>“As a result of fairly extensive outreach to the public, we have incorporated feedback and will notify you about the changes,”  said Ted Fick, commission member, at the beginning of the meeting.  </p>
<p>Port commissioners then discussed a number of initiatives including new signs, light rail changes and walkway improvements.</p>
<p>The public testimony about the trees was arousing. </p>
<p>State senator Karen Keiser kicked off the testimony: “I want to report, from my constituents an increasing number of complaints and expressions of anxiety and fear about their environment and their quality of life,” she said. The runway repairs, among other advancements within the past several years have been taking a toll. She talked about the tree project. “I commend you and appreciate your responsiveness to changing your approach on the trees. I do want to caution you… please think about our quality of life to our people here in King County.”</p>
<p>Another testifier said that airplane landing and departure changes are creating challenges regarding heightened airplane emissions. “Our trees are our only mitigation, they protect us from sound and environment,” he said.</p>
<p>“I’m here to talk about trust and responsibility,” another testifier said. An activist in the city, he said he recently requested information from the FAA (Federal Aviation Administration). “It goes to the issue of trust. We were originally told that the FAA made [the tree project." However, one of the FAA’s letters stated: "I want to make it clear that at this time the FAA has not said that the airport should be doing this. Based on the information we have [the is not in violation.”</p>
<p>The citizen said that information like this degrades trust. Why not have an environmental review, he asked? “Just because you can do something, it doesn’t mean you should. There are a lot of alternatives to save the trees. There is a lot of suspicion that there is an alternative motive for this.”</p>
<p>Another citizen also testified about the tree-cutting project, dubbed the Flight Corridor Safety Program. “We ask that you include additional and ample opportunities for community input and that they are clearly discussed,” before the trees are cut. He also thanked the commission for funding awards it received, as well as work done regarding Sound Transit.</p>
<p>“I want to thank you for involving the community,” in the tree-cutting project, another testifier began. “Cutting trees breaks my heart, though sometimes it is necessary and if it is, I ask you keep [the trees Memorial Drive.” She said she would also like to take each of the commission members on a drive in Memorial Drive to point out how it needs to be restored. “We need a place in the community to give a place to folks who gave their lives for this country,” she said. </p>
<p>Yet another citizen asked the commission to “postpone” the first phase of the tree-cutting project. “We want you to do an [environmental on the first phase. "Deviding this project into phases does not relieve you of the responsibility to bypass the,” she said.</p>
<p>Another citizen, with an environmental group said, “there is no way to run an airport to protect our children’s rights without cutting emissions by 10 percent,” he said. “Our chances for improving life for our children is becoming unmanageable… These trees, especially trees in urban areas are precious. We’re taking away our kids’ ability to breath so more trees can fly around. That’s a crime against humanity.”</p>
<p>“I am speaking for the trees,” another citizen said. “Trees over 30 years old is the average age of trees in our neighborhood and that’s when they start to give back their value,” she said. “We need to keep the older ones,” since they provide the most health benefits. “Our health is physical, economical and emotional. We don’t have to do the old way of doing things — cutting everything. The necessity and benefit of trees has been well known.” She read a piece of writing from the Duwamish culture, which articulated how trees vitally improved children’s health.</p>
<p>“The age of the trees are very much being considered,” commission member Fred Felleman responded to her testimony.</p>
<p>"It doesn’t look like the FAA requires trees to be cut at all", another testifier said. She stated that not doing an environmental review for phase one is unusual and unnecessary. She also said that it would be nice for the Port to have all their documentation in one, transparent place for community members to see. “This is inappropriate,” she said. Additionally, the Port should go to the private property owners to ask for permission to cut down their trees before it goes ahead with the three-year project. “This gives me a lot of angst,” she said.</p>
<p>A youth testified, who said he is a climate ambassador for 4th graders. “These trees provide a large part in blocking sound, which is already very loud.” The youth said he plays baseball in the area. "This unjust plan will impact me and everyone else. The trees can’t speak for themselves, that’s why I’m here.”</p>
<p>The young person’s testimony received a round of applause.     </p>
<p>Another citizen said the reason why the trees are being cut in the fist place is to make money. However, residents don’t care about the Port’s profits — they care about their personal health and physical wellbeing. He said the tree-cutting project is similar to Flint, Michigan’s situation with the government allowing the drinking water to be poisoned, just because it was economically advantageous to politicians. “If you really care about us, you’ll really care about all aspects of our society,” he said.</p>
<p>Felleman responded that the Port needs to readdress its mission statement.</p>
<p>The commission heard more testimony, and discussed other agenda items. <div id="gam-holder-west-seattle_story_text_region_slot_2" class="gam-holder"><script type="text/javascript">GA_googleAddSlot("ca-pub-4956332358238235", "west-seattle_story_text_region_slot_2");</script><script type="text/javascript">GA_googleFillSlot("west-seattle_story_text_region_slot_2");</script></div></p>
    <ul class="links inline"><li class="addthis first"><span>
      <a class="addthis-button" href="http://www.addthis.com/bookmark.php"
        onfocus="return addthis_open(this, '', '[URL]', '[TITLE]')"
        onmouseover="return addthis_open(this, '', '[URL]', '[TITLE]')"
        onblur="addthis_close()"
        onmouseout="addthis_close()"
        onclick="return addthis_sendto()"><img src="http://s9.addthis.com/button1-share.gif" width="125" height="16" alt="share" class="addthisimage" /></a><script type="text/javascript" src="http://s7.addthis.com/js/152/addthis_widget.js"></script></span></li>
<li class="fb_social_like"><span><div class="fb-social-like-widget"><fb:like  href="http://www.westseattleherald.com/2016/11/22/news/residents-livid-about-port%E2%80%99s-plans-cut-3000-trees" send="false" layout="button_count" show_faces="false" width="100" action="like" font="verdana" colorscheme="light"></fb:like></div></span></li>
<li class="tweet_Twitter last"><a href="http://twitter.com/?status=http%3A/%2Ftinyurl.com/jhucq5e%20Residents%20livid%20about%20Port%E2%80%99s%20plans%20to%20cut%203%2C000%20trees%20near%20SeaTac%20Airport" class="tweet" rel="nofollow" target="_blank"><img src="/sites/all/modules/tweet/twitter.png" alt="Post to Twitter" title="Post to Twitter" width="16" height="16" /></a></li>
</ul>        </div><!-- /content -->
  </div>
</div><!-- /row -->

<p id="comments-prepend">We encourage our readers to comment. No registration is required. We ask that you keep your comments free of profanity and keep them civil. They are moderated and objectionable comments will be removed.</p>
<div id="disqus_thread"></div><noscript><div class="disqus-noscript"><a href="http://westseattleherald.disqus.com/?url=http%3A%2F%2Fwww.westseattleherald.com%2F2016%2F11%2F22%2Fnews%2Fresidents-livid-about-port%25E2%2580%2599s-plans-cut-3000-trees">View the discussion thread.</a></div></noscript>

                                                                  </div><!-- /content-content -->
                                                              </div><!-- /content-inner-inner -->
                            </div><!-- /content-inner -->
                          </div><!-- /content-region-inner -->
                        </div><!-- /content-region -->

                                              </div><!-- /content-group-inner -->
                    </div><!-- /content-group -->

                    <div id="sidebar-last" class="sidebar-last row nested grid12-4">
<div id="sidebar-last-inner" class="sidebar-last-inner inner clearfix">
  
<div id="block-google_admanager-112b30eb96b14bd99046dc4c7ded012c" class="block block-google_admanager odd first  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-west-seattle_news_region_1_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("west-seattle_news_region_1_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-b433dcd3b70c0b8def84cb8ca10cea2d" class="block block-google_admanager even   grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-west-seattle_news_region_1_slot_2" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("west-seattle_news_region_1_slot_2");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-028ab4d2898fe772cc29f90dbcd8fdc7" class="block block-google_admanager odd   grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-west-seattle_news_region_2_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("west-seattle_news_region_2_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-block-10" class="block block-block even  grid12-2 black-header">
  <div class="inner clearfix">
            <div class="content">
      <p>Please send us your news tips, photos or ideas of how we can better cover your neighborhood. </p>
<p>Email us at <a href="mailto:westseattle@robinsonnews.com">WestSeattle@robinsonnews.com</a></p>
<p>or TEXT news tips to 206-459-6717</p>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-block-9" class="block block-block odd  grid12-2 black-header">
  <div class="inner clearfix">
            <div class="content">
      <p><a href="http://twitter.com/westseattleher"><img src="/sites/robinsonpapers.com/files/followusontwitter.png" /></a> </p>
<p>Receive updates on news and events in the West Seattle neighborhood via Twitter!</p>
    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
  
<div id="block-google_admanager-492a440897f5a21ed121519201b967ef" class="block block-google_admanager even  last  grid12-4 black-header">
  <div class="inner clearfix">
            <div class="content">
      <div id="gam-holder-west-seattle_news_region_3_slot_1" class="gam-holder"><script type="text/javascript">GA_googleFillSlot("west-seattle_news_region_3_slot_1");</script></div>    </div>
  </div><!-- /block-inner -->
</div><!-- /block -->
</div><!-- /sidebar-last-inner -->
</div><!-- /sidebar-last -->
                  </div><!-- /main-content-inner -->
                </div><!-- /main-content -->

                
              </div><!-- /main-group-inner -->
            </div><!-- /main-group -->
          </div><!-- /main-inner -->
        </div><!-- /main -->
        
      </div><!-- /main-wrapper -->

                    
      <!-- postscript-bottom row: width = grid_width -->
                    
</div><!-- /content-container -->

      <!-- footer row: width = grid_width -->
      
      <!-- footer-message row: width = grid_width -->
      <div id="footer-message-wrapper" class="footer-message-wrapper full-width">
        <div id="footer-message" class="footer-message row grid12-12">
          <div id="footer-message-inner" class="footer-message-inner inner clearfix">
                        
            <b>Web development by <a href="http://freelock.com" target="_blank">Freelock Computing</a></b>
            &copy; 2016 Robinson Communications Inc. All Rights Reserved.
            <a href="/contact-us">Contact Us</a>
              <a href="/terms_of_service">Terms</a>
              
                                    <a href="/robinson-newspapers-subscription-form">Home Delivery</a>
                                    <a href="/feed" rel="alternate" type="application/rss+xml">
            <img src="http://www.feedburner.com/fb/images/pub/feed-icon16x16.png" alt="" style="vertical-align:middle;border:0" />
            </a><br>
            Media kit available on request -- contact Donao@robinsonnews.com
          </div><!-- /footer-message-inner -->
        </div><!-- /footer-message -->
        <br class="clear" />
      </div><!-- /footer-message-wrapper -->

    </div><!-- /page-inner -->
  </div><!-- /page -->
  <div id="fb-root"></div><script type="text/javascript">
     window.fbAsyncInit = function() {
       FB.init({
         appId: "",
         status: true, 
         cookie: true,
         xfbml: true,
         channelUrl: "http:\/\/www.westseattleherald.com\/fb_social\/channel"
       });
       
       FB.Event.subscribe("edge.create", function(href, widget) {
_gaq.push(["_trackEvent", "Facebook like", "Drupal", href]);
});
       
         
     };
     (function() {
       var e = document.createElement('script'); 
       e.async = true;
       e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
       document.getElementById('fb-root').appendChild(e);
     }());
  </script><script type="text/javascript">
<!--//--><![CDATA[//><!--
var _paq = _paq || [];(function(){var u=(("https:" == document.location.protocol) ? "https://pilchuk.freelock.com/" : "http://piwik.freelock.com/");_paq.push(["setSiteId", "23"]);_paq.push(["setTrackerUrl", u+"piwik.php"]);_paq.push(["setDownloadExtensions", "7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"]);_paq.push(["setDoNotTrack", 1]);_paq.push(["trackPageView"]);_paq.push(["setIgnoreClasses", ["no-tracking","colorbox"]]);_paq.push(["enableLinkTracking"]);var d=document,g=d.createElement("script"),s=d.getElementsByTagName("script")[0];g.type="text/javascript";g.defer=true;g.async=true;g.src=u+"piwik.js";s.parentNode.insertBefore(g,s);})();
//--><!]]>
</script>
  
  <!-- Start Quantcast tag -->
  <script type="text/javascript">
    _qoptions={
      qacct:"p-04cWTlFWpKYdM" 
    };
  </script>
  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
  <noscript>
    <img src="http://pixel.quantserve.com/pixel/p-04cWTlFWpKYdM.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>
  <!-- End Quantcast tag -->
</body>
</html>

